My meta image is not showing up in the link previews on Social Media

This can happen for multiple reasons, but don't worry.

1) Try to use the Social Media Platform's Debug Tools

It could be that the Social Media Platforms have not checked your site for a new image yet. You can tell them to do that!

Facebook Debugger Tool

Go to the Facebook Debugger Tool, enter the URL of your article and click "Debug". You will see which information Facebook has about your post at the moment, including your image that might be missing. Then click "Scrape again". Your new image should now be displayed. (image)

Twitter Card Validator

Go to the Twitter Card Validator, enter the URL of your article and click "Preview Card". You will see a preview of how the link will look like when shared in a tweet. Your new image should now be displayed. (image)

LinkedIn Post Inspector

Go to the LinkedIn Post Inspector, enter the URL of your article and click "Inspect". You will see a preview of how the link will look like when shared on LinkedIn. Your new image should now be displayed. (image)

Pinterest URL Debugger

Go to the Pinterest URL Debugger, enter the URL of your article and click "Validate". Try pinning your article on Pinterest again. Your new image should now be displayed. (image)

Did your image still not show up? Then try this:

2) Check the Placid image generation status

It could be that your image is still in the queue to being generated by Placid. Visit the image URL of the page where your image does not show up yet. If it's still in the generation queue, you will see a message appear that tells you that. Please wait a few minutes and check back.

Tip: You can use our Social Share Preview plugin for Chrome to quickly see which image appears on different Social Media on every page you visit.